Clientsettings.cfg Not Working for __RelayServer1

I’ve seem to have hit a wall. We have clients that are within subnets that cannot communicate back with the root bes server. We have been trying to use clientsettings.cfg file to set the primary and secondary relays without success. I’ve pasted an edited copy of our file below.


We are able to run the following command from the bes client successfully.


Which returns the following:


I have tried varying versions of the clientsettings.cfg file using quotes and then not using quotes. What is really frustrating is that it takes other parameters such as __LockState and __RelaySelect_Automatic just fine but it won’t set the primary, secondary, or failover relays.

Each time I uninstall the BES client I blow away the registry entries so the install starts fresh and I’m using the setup installer and not the MSI installer.

Any thoughts would be helpful, any way to increase debugging to see if its choking on something in the clientsettings.cfg file?

We used to have a similar situation where we had clients blocked from communicating directly with the main server. We used this copied directly from our clientsettings.cfg file:


We set both relay settings to the same relay computer. Maybe try the relayselect line before the relay server lines. We used the setup.exe installer with this file and it worked fine for years.

– Aaron

@amelgares has the right set of settings.

There is a shortcut to do this as well and its



Relay IP=http://fqdn:52311/bfmirror/downloads/

I’m not 100% sure the quotes are required as none of that should have spaces in it either

Either of the above should expand into the 3 settings like @amelgares has described

1 Like

Additionally I presume the endpoints are Windows/Mac?

Are the clients showing up in the console at all? One common thing to consider, is that deployments may have a Policy Action configured that changes the clients to Automatic Relay Select mode. When we engaged IBM for our first deployment, they configured such a policy action while they were here, so I think that is a common approach.

If that’s the case, you’d see the client appear in the console, then shortly after it will stop updating. If the client is trying to use Auto Relay Select, it will need to be able to talk ICMP with the relays.

Thanks Aaron,

Just tried putting RelaySelect first but still no dice, I guess it’s time to open up a support ticket. We don’t have any open actions that are reconfiguring the end points. I’ve tried the client settings with and without quotes but have the same results.


The endpoint is a Windows 7 machine.


Client shows up in the console but without a primary of secondary relay.

Wanted to provide an update, we figured out that deleting the registry entry was not enough, we had to uninstall the bes client, delete the registry keys, and manually delete the client folder to get the client settings to take. After we did this it would accept any configuration including IP, Relay IP, and RelayServer1, etc. Thanks for all of the help.

1 Like

If it’s showing up in the console, then it was able to contact a relay.

Was this an initial install, or did the client move to a new network?

One hack we’ve used when our clients get into a bad state relay-wise, has been to put an entry in the hosts file that maps the bigfix server’s hostname, to the address of a relay the client can reach. Once the client is checking in, we can use the console to fix whatever else is wrong. Beats a reinstall.

Just uninstalling the client doesn’t remove everything as you found out, but there is a tool so that you don’t have to do it all by hand:!/wiki/Tivoli%20Endpoint%20Manager/page/TEM%20Remove%20Utility

Hi Jamestford,

Can I have the client log file from one of the problematic machine ?


According to this:

The first lines of the clientsettings.cfg to set a different relay to use instead of the root for a client’s first connection are this:


I recently was in this situation and used the above and it worked for me.

As @TimRice mentions below, you must use the EXE installer on Windows.

I just had occasion to show one of our groups how to install the Client on machines that were “outside” our firewall.

@jgstew lists the correct format to use in the clientsettings.cfg file. We used it on several Macs and several Windows systems to register clients via our DMZ Relays. You do have to use the EXE client installer for the clientsettings.cfg file to have an effect.

1 Like

I’m having a similar problem. My file looks like this:


…but when clients are on our wireless network, they bootstrap to

For the life of me, I can’t figure out how it goes to relay1 instead of relay2, as specified. It’s maddening.

If I add


It runs a relay selection and winds up at the core server! (Yeah, I know, protect the root… I’m working on that.) Both relays can be reached via ICMP and http:52311.

I’m stumped.

You may want to run the client diagnostics with the -r to run a relay selection test to see how the computer is selecting relays. You can also use the relay parser to see what list of relays it has received from the core server.

1 Like

I would also set the primary relay as relay2

Maybe I’m mistaken. I thought there was another client setting to set the primary relay for manual selection as well.

If you turn on automatic selection in the CFG file then your settings for the selected relay don’t “match” the available set for the deployment (as you have a chicken and egg problem as you haven’t gathered the available set yet) so it will try to go to root.

The settings should be for a manual configuration and then you can change it after it gathers.

The “Relay IP” or “IP” will set __RelayServer1, __RelayServer2 to the given value and set __RelaySelect_Automatic to 0

1 Like


Your command worked for me while the documented command of just having the IP: configuration line went to the root server instead of the relay for me. Thanks for the input. The instructions on IBM’s support site were a bit confusing and didn’t really indicate that you needed the second line to make it work.

1 Like

This is mine and it works great:

1 Like