Client stops communicating with BF and changes registry automatically - GetURL failed - General transport failure. - BAD SERVERNAME (winsock error 4294967290 - registration url

Hi Every one,

I am facing a very weird issue on most of my cloud server’s on AWS. For some time they are able to register them self with relay for their specific region and BF client communicate very well. But after couple of hours It try to register itself to the main root server and get transport failure error as below.

RegisterOnce: GetURL failed - General transport failure. - BAD SERVERNAME (winsock error 4294967290 - registration url

Just for Info - Relay for these client is in different subnet and able to telnet relay on 52311 from BF client. I am facing it on some specific AWS accounts where as other AWS account communicate without any issue although they are in different subnet.

Kindly find screenshot of BF log one where client is able to register with relay and another on which face General transport failure.

Thank you,
Jaspreet Singh

Could i get some expert advice on this? Thanks in advance ?

Can you Ping the relay also? ICMP is required for automatic relay selection.

1 Like


In addition to Jason’s suggestion, I would recommend configuring a Last fallback Relay ( that uses a DNS name that is resolvable by all your Clients to an appropriate Relay, regardless of location. This way, rather than Clients falling back to the Root Server, you can appropriately re-direct Clients to an available Relay.

1 Like

Thanks for input, will give it a try.

cant ping as its blocked on AWS environment and need to check if ICMP is allowed or not. But main concern is that We have other server’s who directly communicate with BES root server, using it as a relay…then why these machines are not able to, that’s what I am trying to figure out. I think it’s something related to network issue as facing issue on particular set of subnet for AWS environment but need to be sure about that.


Change primary relay of problematic machine then restart besclient service . i hope this will work.

thanks for input, but we have tried doing it N number of time. It will communicate for some time and again it will try to register it with self Top level relay and then stop communicating. We have like 6 low level relays for 3 region and client is able to communicate with low level relay but that only for some time and then it stops.

You may need to check the action History for the machine, or read through a much longer snippet of the client log.

A very common setup is to have a Policy Action switching clients to use Automatic Relay Select. If you have something like that in your deployment, it would explain the behavior that your manual relay selection works for a while but is then changed by your policy action.

1 Like

We do have a Policy Action to switch client to use Automatic Relays, We have 3 regions ADC, EDC & PDC, and as per relay affiliation seeklist server should connect to one of the relay from this seeklist, which it does for some time say 1 or 2 hour.

And we are facing this issue only for couple of subnet on cloud machines. Can it be something related to Firewall ? I am just assuming/guessing.

I have gone through the logs as well and I am not able to find anything in that. when it Begin Relay Select - it communicate with relay to its specific region and after wards say like 1 or 2 hours it will try to register to the Root server as a relay and there I get below mentioned error.

RegisterOnce: GetURL failed - General transport failure. - BAD SERVERNAME (winsock error 4294967290 - registration url

If the client cannot Ping the relay, it will not use that relay for auto-selection. So the first step is to validate whether you can ping.

1 Like

Finally Issue is resolved…due to policy on firewall ICMP was blocked due to which clients were not able to select the nearest relay and more over upon further troubleshooting Tenet to 52311 for TLR was not enabled…
@JasonWalker thanks for help…

1 Like

Hii jas I was also stucked with the same error can u please help me.

@aiijaz - did you checked if clients are able to telnet to port and also if they are able to ping the relay and then root server ?

@jas.itpro sorry for the late the issue resolved by putting the relay entry in the server

HI @Aijaz do you mean entry in host file of root server??