Class IllegalFileName or Expression Contained a Character Which is not Allowed

When I run the following relevance in the fixlet debugger single clause it returns: "Error: The expression could not be evalutated: class IllegalFileName. In qna the return is: “This expression contained a character which is not allowed”.

exist ((find files "*.url" of ((descendant folders of it; it) of folders "favorites" of folders of folder "C:\users")) whose (exists (following texts of firsts "=" of variables of it) whose (it as lowercase contains "" OR it as lowercase contains "" )))

The strange thing is that this relevance worked on 99% of the systems I ran it on.

This means there is a file somewhere that has an odd character in it that is causing this error to be thrown. In my opinion the problematic file should just be skipped, rather than throwing an error and halting everything, particularly if plural relevance is used.

CC: @AlanM


Not a bad idea on the skipping part as you can’t really get around it any other way

1 Like

Definitely. Something is better than nothing.

How would I skip the bad file?

You can’t skip the bad file. I’m suggesting that the relevance evaluator should skip the file with the bad name. This is something that would require IBM to fix.

Yes that is correct. I’d suggest it be opened as a PMR to make sure it gets prioritized.

1 Like

I will open a PMR. Would you consider this a bug or a request for enhancement.

1 Like

It is a bug, though I would also file an RFE as well.