CDT "No agent image found in the catalog for..."

Hi. I’m getting this error while running BigFix CDT:

No agent image found in the catalog for CentOS 6.7 x86_64.

Same error exists for other operating systems ( CentOS 7.x, Ubuntu 14.04, Ubuntu 16.04 …)

How to resolve this issue ?
Thanks in advance .

HI There,

Were you able to solve this issue? we started having the same one, and support hasn’t provided a solution yet.


From what I can see, you do not have the catalog. Have you tried to run the deploy tool using the fixlet (or the wizard) available in BES Support? The action will take care of creating the catalog and downloading the client RPMs.

You can find further details here:

The fixlet works fine without problems up to a certain point, the catalog is fine and the sha1 file is there,

this seems to happen at leas for us when you have more than one AD domain, depending on which active directory domain you try to deploy with the CDT (with a corresponding logged in domain admin of each AD), it gives you the error in one of the two domains.

Please run the CDT using “run as administrator” that will work

I’m facing same issue with RHEL 9.4