Can't create WebUI credentials after revoking

Hello Team,

I’m trying to insert an SSL certificate on WebUI, but as soon as I did all the procedure and restarted the server, I got the error:

[WebUI] process started
[WebUI] process exited with code 1 signal 0

I’ve look into this and found the related KB: KB0103932

I could revoke, but when I tried to create it didn’t work. No matter what I try I get an error saying:

The specified output patch is not a directory

Does anybody knows how exactly should I type this code?

I’m on Windows btw.

Thank you.

The /webUICertDir parameter needs to be a path to an existing folder, like


The directory needs to exist before you run the BESAdmin command

I’m stil getting the same error. Do I need to create this folder on the root directory?

I already have this one and inside the “cert” folder there are the standard webui certs.


But when I type in this location, it does not work.

Thank you.

Are you using the “certs” subdirectory or the “BES WebUI” folder root?

The path has spaces in it, have you tried enclosing the path in doublequotes?

The folder “cert” inside “C:\Program Files (x86)\BigFix Enterprise\BES WebUI” was already there, I believe it’s standard. I have no such “certs” folder inside “C:\Program Files (x86)\BigFix Enterprise\BES WebUI\WebUI”

This is what I have inside the WebUI folder:


I have tried double quotes, but no success.

.\BESAdmin.exe /createwebuicredentials /sitePvkLocation:license.pvk /sitePvkPassword:REDACTED /webUICertDir:"C:\Program Files (x86)\BigFix Enterprise\BES WebUI\cert" /webUIHostname:ROOTSERVER



I’m probably doing something wrong, because, as you can see the /sitePvkLocation I had to place it on the root server main folder where the besadmin is located, because I couldn’t get it to recognize the paths I was inserting. I did that on the revoking code and it worked.

Your account probably doesn’t have permission to write into the “C:\Program Files (x86)\BigFix Enterprise\BES WebUI\cert” directory. By default we set it up so only the LocalSystem account (or the service WebUI runs under) has permission to that directory. Try using BESAdmin to create the cert files elsewhere and then move them into the WebUI certs folder (you’ll probably have to grant yourself ownership, Windows Explorer will offer that when you try to copy the cert files in there).

Probably easiest to use Task 2558 “Rotate WebUI Certificates” from the BES support site

I could not manage to make it work and I’m getting an error when specifying the target, which is the root server itself. I’m getting:


And not sure about how can I do this:

Try using BESAdmin to create the cert files elsewhere and then move them into the WebUI certs folder

I don’t see an option to create cert files in BESAdmin.

The problem remais and WebUI is entirely unreacheable.

You should open a support incident so someone can walk through this with you on a call.

1 Like