BigFix BM-OSD Error: Packages not found at path local://root/x$/rbagent.pak

Good Evening,

I’m new to the BigFix world and am trying to proceed with a Bare-Metal Deployment of Win10 Enterprise (Nov-2016)
to both a virtual machine and an HP EliteBook 840 G3.

Tasks Completed:

  • Added resource ISO
  • Created image from ISO
  • Created MDT Bundle using WDK 10
  • Created Profile for Windows 10
  • Bound drivers to image

PXE Boot is working. After I make a selection for the Win10 Profile, the Boot.WIM file loads,
then I am greeted with the following error:

Packages not found at path local://root/x$/rbagent.pak

I have tried recreating the profile, image, bundle, etc.
I’ve also tried an older WIN10 image, same results.

Any thoughts or pointers would be greatly appreciated!

Hi. the message “Running in offline mode” you get just before the “Package not found…” seems to suggest you are running some sort of offline deployment. That means you have created a deployment media of some sort and you are using that media (CDROM or PEN Drive) to boot the system and perform the install. If that is the case you should try to recreate such media.
Under normal circumstances the rbagent.pak is pulled from the server once WinPe is started. As you
are running offline (no connection with the server) the is searched within the booted image (x$ drive) but it is not found.

Hi there, thanks for responding I don’t believe I’m creating an offline installer. I see there is an option for this under the Bundle Creators and Windows Media tab, but I have not selected to do so. Instead I have been using the MDT Bundle Creator tab. Is there a way I could verify that the deploy session is configured for online?

Once the bundle is created I add the IMG, create a baremetal profile, and then bind the drivers.

PXE boot works without error

WINPE drivers bind without error during PXE

BareMetal Profile is selected and then the Boot.SDI and BOOT.WIM files are loaded.

One note: I’ve used MDT in the past via a LiteTouch deploy, the inital loading is quite quick (1-2 minutes) in MDT.
BigFix loading of Boot.WIM takes up to 20 minutes or more. I’m safe to assume this isn’t normal?

Hi, thanks for the info. Also when running in pxe boot flow, once winpe is started and our code begin execution there is a very small time frame were we operate in offline mode. In this context the message “Packages not found at path local://root/x$/rbagent.pak” is only informative as this rbagent.pak file is not needed in this little time frame.
Back to your situation then, if your machine remains in that state for more than a couple minutes, then the problem is that WinPE (or our code in there) just break.

I would suggest to recreate and import again the WinPE (that is created in the MDT bundle creation process).
Please Check MDT Bundle Creation log files for errors. If the problem persist please contact the support team.

For the boot wim download maybe things could improve a bit after some tuning of tftp settings.


We are also facing same issue in our new deployment. Exact same error we are getting when we try bare metal image deployment.

We tried different options different MDT bundles but results are same.

Have you find solution for this issue. If yes then please share the resolution to this issue.

Sagar Deshpande.

Hi Sagar,

The message “Packages not found at path local://root/x$/rbagent.pak” does not indicate a problem as the message is only informative. If your deployment remains stuck at that message, it is an indication that winpe got stuck after it is booted on the machine. This may happen sometimes when dealing with too old or too new hardware compared to the used WinPE. The first think to try in this case is a different WinPE version.

Another possibility is to check the WinPE drivers. You can try that from the bindings tab of the drivers dashboard.

If that still does not work please contact the support team.