BigFix and Service Now Setup

Here is a setup guide for anyone looking to link ServiceNow and BigFix 10.


Thanks for this - very useful supplement to the documentation.


Going through the steps but I don’t see an option to configure it to use a proxy server when connecting to ServiceNow. My windows user does have a proxy set and can get to the internet but when I run “IntegrationServices.exe --ValidateConfiguration” it complains that it can’t reach by ServiceNow URL.

A lot of companies do not allow servers to reach the Internet without setting a proxy within the application and not system wide. Too much risk in allowing as a default to reach the Internet from a server (win or linux).

Let me follow up with development and see if there is a way to set this

CS0122739 was created for this too.

I just heard back from Dev.

While proxy configurations are not currently supported, from a process perspective, we recommend creating an Idea (, which we will evaluate for inclusion in future releases. We understand and agree with the requirement.

Can you submit an idea and ill be glad to publish to get my vote.

If you would please vote on the enhancement. I have passed along this feedback to product management to hopefully get this ball rolling for an enhancement or work around for you guys to test.

1 Like

Any idea if there is a work-around option? Would it make a difference if I set the proxy in the host OS?

At least for Windows I tried that and it didn’t work. For me my only option was to deploy the adapter to a Win instance running in public cloud where a proxy wasn’t needed.

Thanks cstoneba. I will check that out.

Was able to modify the firewall on our end to skip the Proxy for that URL.