BES SQL remote database

Hi All,

i just want to know Does BES server 9.2 work with remote SQL database which is listening on custom port and not with default one(1433)


Yes, you should be able to leverage a remote SQL database listening on a custom port. When specifying the remote database server, I believe you’d use the following format: <db server fqdn/ip>,<port number>

Many thanks Aram. its works fine with suggested format but i’m not able to find this step in any documentation.

Thanks for the follow up! This is a fair point. We will look into updating the pertinent documentation.

Has there been any documentation developed for this yet? How does using the custom port effect the IBM Administration tool connection and the NT service accounts for FILLDB, GatherDB , Root server , etc. Is there registry settings that can be looked at ? My assumption this is true for Web Reports, BIGFix Inventory/ILMT and SCA as well. Any additional information would be helpful as I will be installing at a customer location 2nd week of Feb.

I’m facing issue here during initial SCA installation. Even with entering ,24103 in Field “host” I get a connection error an see in tema.log:

<DBNAME>,24103', Port 1433. Fehler: 'SQLDEAAN1D,24103'

which leads me to the assumption that still port 1433 instead of 24103 is used?

The format may be hostname:port, please try with that format and check

1 Like

I’ve tried some hostname and port combinations without success. Meanwhile I’m in touch with HCL support.

Finally, hostname:port is correct. Additionally our firewall blocked SQL traffic on port 24103. Now it’s fixed.

1 Like