Autologin settings not working when deployed through BigFix

We are trying to use BigFix to push and execute a Powershell script that involves several reboots. To ensure that the entire script can run without user intervention the script temporarily sets autologon on the client using the standard registry settings. When we run the script locally on the computer ourselves it works fine, after rebooting it automatically logs on and continues the script, but when we execute the script using BigFix, the autologon doesn’t work–after the first reboot the system just sits at the login screen waiting for log on. Has anyone encountered this? Is there anything about the user context that BigFix executes in that would prevent this setting from being applied?

Without seeing your actual content, the best guess I can give is “wow64 redirection”.

BigFix is 32-bit, so by default the reg.exe that it uses is 32-bit, and a call to add a key to “HKLM\Software\Policies” would be redirected to “HKLM\Software\Wow6432Node\Policies” (for example).

Try adding
action uses wow64 redirection false
to your actionscript before calling regedit.

1 Like

also might consider some of the OVERRIDE options:

Yep, this was it. We disabled redirection and now everything seems to be working as expected. Thanks!

I’m definitely bookmarking this, because I can think of a few things we’re working on that it could come in handy for. Thanks.