A couple of BigFix Agents are acting up

Hi

I have a couple of agents having trouble the bigfix agent. They have stopped reporting inn and when i try to restart the service it does not want to stop. I ended up killing the process and starting the service up again. Then i get stuck with this in the log…

This is everything it says and it won’t report anything else. I have tried reinstalling. It work a couple of days and then it goes back to this.

I have about 2000 clients and there are 2 of them who has this error.

We are running 9.2.6 on the whole platform.

Anyone expirienced this or has a fix?

Regards
Melvin

Hello!

I would recommend opening a PMR.

You can enable tracing by setting the following registry keys:
[HKEY_LOCAL_MACHINE\SOFTWARE\BigFix\EnterpriseClient\Settings\Client_BESClient_EMsg_Detail]
“value”=“10000”
[HKEY_LOCAL_MACHINE\SOFTWARE\BigFix\EnterpriseClient\Settings\Client_BESClient_EMsg_File]
“value”=“C:\Program Files (x86)\BigFix Enterprise\BES Client\besclientdebug.log”
[HKEY_LOCAL_MACHINE\SOFTWARE\BigFix\EnterpriseClient\Settings\Client_BESClient_EMsg_EvalLog]
“value”=“1”

Then startup the client and see if you get a better message for where it’s getting stuck.

1 Like

Hi

Jea i thought so to.

Activated the log settings and got this

Wed, 15 Jun 2016 14:37:41 +0200 DebugMessage Using encoding name(s) from settings.

Wed, 15 Jun 2016 14:37:41 +0200 DebugMessage Client version 9.2.6.94 built for Windows 5.1 i386 running on WinVer 6.3.9600

Wed, 15 Jun 2016 14:37:41 +0200 DebugMessage Current Balance Settings: Use CPU: True Entitlement: 0 WorkIdle: 10 SleepIdle: 480

Wed, 15 Jun 2016 14:37:41 +0200 DebugMessage ICU data directory: ‘C:\Program Files (x86)\BigFix Enterprise\BES Client’

Wed, 15 Jun 2016 14:37:41 +0200 DebugMessage ICU init status: SUCCESS

Wed, 15 Jun 2016 14:37:41 +0200 DebugMessage ICU report character set: windows-1252

Wed, 15 Jun 2016 14:37:41 +0200 DebugMessage ICU fxf character set: windows-1252

Wed, 15 Jun 2016 14:37:41 +0200 DebugMessage ICU local character set: windows-1252

Wed, 15 Jun 2016 14:37:41 +0200 DebugMessage ICU transcoding between fxf and local character sets: DISABLED

Wed, 15 Jun 2016 14:37:41 +0200 DebugMessage ICU transcoding between report and local character sets: DISABLED

Wed, 15 Jun 2016 14:37:41 +0200 DebugMessage EMSG Logging Detail Level set to: 10000

Wed, 15 Jun 2016 14:37:41 +0200 DebugMessage Starting client version 9.2.6.94

Wed, 15 Jun 2016 14:37:41 +0200 Relay Selection: Setting control server

Wed, 15 Jun 2016 14:37:42 +0200 DebugMessage FIPS mode disabled by default.

Wed, 15 Jun 2016 14:37:42 +0200 DebugMessage Cryptographic module initialized successfully.

Wed, 15 Jun 2016 14:37:42 +0200 DebugMessage Using crypto library libBEScrypto - OpenSSL 1.0.1p-fips 9 Jul 2015

Wed, 15 Jun 2016 14:37:42 +0200 Running
Wed, 15 Jun 2016 14:37:42 +0200 DebugMessage Adding sites

Wed, 15 Jun 2016 14:37:42 +0200 DebugMessage Restricted mode

Wed, 15 Jun 2016 14:37:42 +0200 DebugMessage Not in grace period

Wed, 15 Jun 2016 14:37:42 +0200 DebugMessage Adding sites in map

Wed, 15 Jun 2016 14:37:42 +0200 DebugMessage Initializing Site: BES Asset Discovery

Wed, 15 Jun 2016 14:37:42 +0200 DebugMessage Initializing Site: BES Support

Wed, 15 Jun 2016 14:37:42 +0200 DebugMessage Loading file to side line. C:\Program Files (x86)\BigFix Enterprise\BES Client__BESData\BES Support\Libraries.fxf

Wed, 15 Jun 2016 14:37:42 +0200 DebugMessage Initializing Site: CustomSite_A20_-2d_Undervisningsbygg_Oslo

Wed, 15 Jun 2016 14:37:42 +0200 DebugMessage Initializing Site: Enterprise Security

Wed, 15 Jun 2016 14:37:42 +0200 DebugMessage Loading file to side line. C:\Program Files (x86)\BigFix Enterprise\BES Client__BESData\Enterprise Security\2007 Non Security Updates (x64).fxf

Wed, 15 Jun 2016 14:37:42 +0200 DebugMessage Loading file to side line. C:\Program Files (x86)\BigFix Enterprise\BES Client__BESData\Enterprise Security\2004 Non Security Updates (Apps).fxf
Wed, 15 Jun 2016 14:37:42 +0200 DebugMessage Initializing Site: Patching Support

Wed, 15 Jun 2016 14:37:42 +0200 DebugMessage Initializing Site: Updates for Windows Applications

Wed, 15 Jun 2016 14:37:42 +0200 DebugMessage Initializing Site: mailboxsite

Wed, 15 Jun 2016 14:37:42 +0200 DebugMessage Initializing Site: opsite114

Wed, 15 Jun 2016 14:37:42 +0200 DebugMessage Initializing Site: opsite115

Wed, 15 Jun 2016 14:37:42 +0200 DebugMessage Initializing Site: opsite119

Wed, 15 Jun 2016 14:37:42 +0200 DebugMessage Initializing Site: opsite120

Wed, 15 Jun 2016 14:37:42 +0200 DebugMessage Initializing Site: opsite130

Wed, 15 Jun 2016 14:37:42 +0200 DebugMessage Initializing Site: opsite131

Wed, 15 Jun 2016 14:37:42 +0200 DebugMessage Initializing Site: opsite132

Wed, 15 Jun 2016 14:37:42 +0200 DebugMessage Initializing Site: opsite136

Wed, 15 Jun 2016 14:37:42 +0200 DebugMessage Initializing Site: opsite14

Wed, 15 Jun 2016 14:37:42 +0200 DebugMessage Initializing Site: opsite141

Wed, 15 Jun 2016 14:37:42 +0200 DebugMessage Initializing Site: opsite142

Wed, 15 Jun 2016 14:37:42 +0200 DebugMessage Initializing Site: opsite3

Wed, 15 Jun 2016 14:37:42 +0200 DebugMessage Valid operator set loaded from action site masthead

Gonna send it in as a problem. Thanks for the tips