Windows Software Distribution Wizard - Newb Help/Deployment not working

Hi All,

Relatively long time listener, first time caller. I’ll start off by saying I’m not a coder, but I’m trying to figure it out. So, I’ve been trying to set up a deployment for Sophos Guest VM Agent. It’s an .exe and I’ve gone through the wizard following proper order of things and using switches to run independently of the users knowledge. I mean the wizard seems to follow a logical order, how hard can it be? Once it’s setup, I attempt to run the new fixlet and typically it is stuck on pending download, I’ve even let it set there for a few hours just to see if it would work. So, to me it would seem I’ve done something wrong. After searching and reading trying to understand this all, I figured I’d approach the all-knowing forum. Thanks in advance for any help.


In the Summary tab of the Action, there should be a ‘Downloads’ section. Does that section show the files associated with the action as cached on the server?

Hi Aram, thanks for replying. Yes, the downloads section shows the file, but with a .tmp after the .exe, which makes sense (I think). The Status column is Complete and Details column says Cached on Server.

So I’ve recreated a software deployment and it goes clear until the status is Completed, but when I check the machine to verify it installed properly, the icon is a default Windows icon, and basically it’s not the full software package that was supposed to be deployed. Not sure what the problem is.

How is this going? did you figure it out?
Silly question are you trying yo re-package the entire thing?

I’ve tried a few times to create a deployment that works. I’ve used an .exe and a .msi and can’t seem to get it to install properly. I’ve used the basic switches and detailed switches to make the install as quiet as possible all with the same result. BigFix will say Completed, I check the machine to verify, and I see it installed, but with a default Windows icon and the Publisher just says a single name, not what you would see when you install it on the machine directly. I hope makes sense.

worst Case Scenario you can look into repackaging the application. tho, you can re-download it and try again. I do know this is a tricky installation. I would ask your desktop guys if you have them or unless is just you o.O who process they go thru install the application.

Does the MSI package support a per-user install? You may need the ALLUSERS=1 parameter on the msiexec command line.

I’ll take a look. Thank you. This particular problem deployment is a .exe and I’m starting to wonder if it’s the .exe that’s the problem. I recently deployed another .exe and it worked perfectly. So, who knows what the problem is. Currently the latest deployment is saying running, and has been for the last 12 hours. Is there a way to see what it’s doing or what it might be hung up on?