Upgrades to Version 7.1.1.315 failing or not relevant

(imported topic written by curth)

I am trying to upgrade my Development environment (50 seats) to v7.1.1.315. The Upgrade to the Server and the Console software ran successfully (though, a second (duplicate) entry showed up for BES (Dev) Server - no biggie). I have run into a couple other issues which are preventing me from continuing forward:

  1. I ran the fixlet to upgrade the Installation folders. The fixlet ran and returned a status of “Failed”. When looking at the details of the Action Info, all of the action items show as “Completed”. Looking at the installation folders themselves, it appears that they were upgraded. Looking at the registry key for the BigFix Enterprise Suite Installation Generator, the DisplayVersion is 7.1.1.315. I tried plugging in the relevance for this fixlet into the QnA tool and it returns “No inspector context.” When I broke down the relevance into its parts, two parts were responsible for this return message (evaluation of client license = false) and (version of registration server >= “7.1”).

  2. The Fixlet for upgrding the BES Relay to v7.1.1.315 is also not showing as relevant for my Relay Servers. As above, I broke down the relevance and found that all relevance statements resolved correctly with the exception of the two relevance lines (evaluation of client license = false) and (version of registration server >= “7.1”). They both return “No inspector context.”

Any ideas why this is happening?

(imported comment written by curth)

OK, I figured out my first issue with the upgrade to the Installation Folders. Turns out that I have two registry keys for the Installation Generator - one for v7.0.1.376 and now one for v7.1.1.315. Since the key for v7.0.1.376 is still in the registry the Fixlet showed as Failed and still shows as relevant. After removing that key, the Fixlet no longer shows as relevant for this server.

Now, I just need to figure out why the Fixlet to upgrade the BigFix Relay is not showing as relevant.

(imported comment written by curth)

I figured out the second issue. When I deployed the fixlet to upgrade the Server and Console, I had the console open on the BES Server. As the console upgraded, I threw an error message. This was expected since the console software was open, so I rebooted the server a few minutes later. I thought that the BES Server software had been upgraded, however, it was not. I am now trying to run the Fixlet again to upgrade the BES Server software.

(imported comment written by BenKus)

Hey curth,

The BigFix Relay and Agent first require that the BigFix Server is upgraded which is why they have the clause

(version of registration server >= “7.1”)

. However, the “version of registration server” inspector is only updated when the agents register (which they do by default every six hours)… You can send the agents a refresh or you can restart them to make the register sooner.

We do try to make you aware of this behavior with a note in the Server and Agent upgrade Fixlets:

From the Server upgrade Fixlet:

+BES Clients: The BES Clients will notice that the BES Server is updated and will begin to report the upgrade Fixlet message relevant (the BES Clients by default check once per six hours for the version of the BES Server). It is recommended that you target the BES Client upgrade Fixlet message at “All Computers” instead of “Specific Computers” to make sure to upgrade all BES Clients who have not yet reported. +

From the Agent upgrade Fixlet:

Note: This Fixlet message will only become relevant on computers after the BES Server has been upgraded. It may take a little while for the BES Clients to notice that the BES Server is upgraded.

I expect that by now, all your upgrade Fixlets should be relevant.

Hopefully it is all working for you now…

Ben

(imported comment written by curth)

The upgrade to the server was not completely successful. It appears that all of the components were upgraded, however, the registry was not updated properly. The Analysis for BES Component Versions still shows the BES Server at v7.0.7.82. This is because the Version value for the HKLM - SOFTWARE - BigFix - Enterprise Server key is still set to this version.

I have tried to run the BES Console/Server upgrade Fixlet again to correct this, however, the fixlet stays in a “Running” state and all of the BES services are stopped. When I restart the BES services, the Action then returns a status of “Failed”.

Any suggestions on how to correct this without having to perform a complete uninstall and reinstall of BigFix?

(imported comment written by curth)

I downloaded the “BESServerUpgrade-7.1.1.315.exe” file and ran it manually in hopes to correct the Version Number in the Registry, but to no avail. The upgrade program only shutdown the BES Services.

Is there a setup log that I can look at for further troubleshooting? I couldn’t find any. I guess my next step is to engage Support.

(imported comment written by SystemAdmin)

Curth, I would contact support, my guess would be that you shut down the BES Server in the middle of the original installation and that left the installers in an in between state. You’ll probably want to try to uninstall the BES Server and reinstall it at 7.1.1.315.

(imported comment written by curth)

Support had me completely uninstall the BES Server and then reinstall. Because of the way this failed, I had to go searching through the registry to remove all of the relevant reg keys so the reinstall would work. I was finally able to reinstall the BES Server from my original version. The BigFix Console, however, would not start up because the BES Database had been upgraded by the first attempt at upgrading. So, I manually upgraded the BigFix Server (outside of the Console). Everything is back up and running fine now.

Unfortunately, I can’t test to see if this same thing will happen to my Producton Environment. I’ll cross my fingers and hope for the best. Based on past experience with upgrades in my production environment, I suspect things will go fine.

(imported comment written by rdamours91)

I ran the fixlet to upgrade to 7.1.1.315 from 7.0.9.164 (the client log on the server shows that the upgrade for the server and console is successful…no longer relevent). The Bes services after 2 hours are still stopped. Just wondering how long I should wait for the services to restart on their own and for the backend db stuff to finish before rebooting. Just wondering what logs, etc to check to see where it’s exactly at…

(imported comment written by rdamours91)

All is well that ends well. I found that the programs updated but the db was still at the prior version. I ran the manual upgrade and everthing is back on track.