Proper way to call client folder?

(imported topic written by amagewick91)

I have this line at the end of one of my action scripts

wait cscript.exe “{pathname of client folder of site “actionsite” & “__Download\UpdtDellWiFiA37XP.vbs”}”

Is this the proper way to call the file “UpdtDellWiFiA37XP.vbs” that exists in the folder shown below?

c:\Program Files\BigFix Enterprise\BES Client__BESData\actionsite__Download\

My action sticks at “running” this line in the action, and I see cscript.exe running as a process.

The file does exists at this location

The VBS is supposed to throw a window with TEXT, OK, CANCEL - but I am seeing nothing come up on screen

If I manually run the file, it works fine.

I have used this VBS before and it worked fine, but it was on BES 7.2. Were there any changes that would affect this?

(imported comment written by MattBoyd)

Deja vu: http://forum.bigfix.com/viewtopic.php?pid=23226#p23226

You need RunAsCurrentUser.exe: http://forum.bigfix.com/viewtopic.php?pid=23128#p23128

(imported comment written by amagewick91)

I will try to see if runascurrentuser works. I didn’t have to do this before… so did something change? I am going to test another task that I know worked 100% before on 7.2 and see what happens first. I’ll let you know.

(imported comment written by MattBoyd)

Did you change operating systems? Windows XP used to allow services to run processes interactively, but Microsoft put a stop to that (for good reasons) starting with Vista.

If you’re using XP, it could also be because “allow service to interact with desktop” isn’t enabled for the BES Client service.

(imported comment written by amagewick91)

Interesting… I tried my previous task and it is doing the EXACT same thing. This is for windows XP

Enabled the “BES Client Setting: Download Throttling” and tried again… my original task now works as it used too.

(imported comment written by amagewick91)

The Setup.exe is running as my logged on user, but it is NOW saying “Windows XP Setup - Please go to control panel to install and configure system components.”

Aahh!! lol If I run the VBS file manually, it works just fine.

I think I may go about this another way…

(imported comment written by amagewick91)

Here is my action

download http://10.1.1.185:52311/Uploads/0e93cfe0473a67eaf7d5a78cca86cd135c6e7593/lat2120_nic_drvr_win_a37.tmp
continue if {(size of it = 123593958 AND sha1 of it = "0e93cfe0473a67eaf7d5a78cca86cd135c6e7593") of file "lat2120_nic_drvr_win_a37.tmp" of folder "__Download"}
extract lat2120_nic_drvr_win_a37.tmp
 
delete __createfile
delete __Download\UpdtDellWiFiA37XP.vbs
createfile until endoffile
 
intAnswer = Msgbox("Your Wireless software requires an update! Press OK to continue", vbOKCancel)
If intAnswer = vbOK Then
dim shell
set shell=createobject("wscript.shell")
shell.run "setup.exe"
set shell=nothing
Else
End If
 
endoffile
 
move __createfile __Download\UpdtDellWiFiA37XP.vbs
 
prefetch RunAsCurrentUser.exe sha1:5512ef51a98dff1aa910a8189a0361c161fa703f size:212992 http://software.bigfix.com/download/bes/util/RunAsCurrentUser-2.0.2.exe
waithidden __Download\RunAsCurrentUser.exe --w cmd.exe /c cscript.exe "{pathname of client folder of site "actionsite" & "\__Download\UpdtDellWiFiA37XP.vbs"}"

(imported comment written by amagewick91)

So when the client calls this VBS file, it uses “C:\Windows\System32\Setup.exe” and not the Setup.exe in the client folder. this is the reason for the current message I am getting about using Control Panel

I am going to revert back to a previous version of my script and see if I can get it working.

UPDATE: It is now working. I will post my final after I make a few tweaks to it.