OS Deployment 2 Released!

(imported topic written by JackCoates91)

IBM is pleased to announce phase 2 of Tivoli Endpoint Manager OS Deployment, formerly known as BigFix OS Deployment for Windows. Tivoli Endpoint Manager OS Deployment, which is part of the Lifecycle Management suite, provides a consolidated, comprehensive solution to quickly deploy new Windows workstation operating systems throughout a network from a single, centralized location.

New Features

  • Health Checks Dashboard – A summary of the overall health of your deployment, including a list of tasks you might need to address within your deployment.
  • Image Library – An integration of the Activate Image and Manage Image dashboards from version 1.5, with added functionality to pre-cache images and modify image information.
  • Re-Image History Dashboard – A new dashboard that displays in-progress or completed re-image jobs.
  • SMB shares are no longer required for OS re-imaging.
  • Images can now be stored in any share location and no longer require repositories. When uploaded, images can be pre-cached to any relay as part of deployment preparation.
  • The simplified UI utilizes Take Action Dialogs instead of the dashboard UI for initiating tasks.
  • OS Deployment now supports capture and deployment of Windows Vista.

Published site version:

OS Deployment, version 2

Actions to Take:

Lifecycle Management customers on 8.x platforms will see the new site under BigFix Management > License Overview. This site should be subscribed to the TEM Server and any Windows workstations which need to be migrated or refreshed. After activating the site, the BigFix OS Deployment for Windows site will be marked “Deprecated” in the Console and may be de-activated when it is no longer needed.

Additional Resources:

The User’s Guide may be downloaded from this URL: http://support.bigfix.com/product/documents/OSD/OSD_Users_Guide.pdf

(imported comment written by StacyLee)

I can see OS Deployment. When I click on “enable” I get a IE Script Error (attache image). Anyone else get this? I am able to subscribe to other sites just fine.

Not urgent since I don’t use this site currently.

(imported comment written by SystemAdmin)

I am getting the exact same message, i was able to enable 2 of the Sites I wanted to but the OSD gives me the same error. I actually am seeing the NoSuchSite reference for a few different errors I am seeing throughout the console.

(imported comment written by SystemAdmin)

Same here. Glad to see it wasn’t just us!

(imported comment written by JackCoates91)

Hi,

is there anything suspicious in GatherDB.log?

(imported comment written by SystemAdmin)

nothing really sticks out in the log since the upgrade. I had some database errors from the morning of the upgrade but since then here is the log. monday morning is when i saw TRC, software deployment, and the OSD. the first two imported and the OSD is the error pictured above.

Thu, 10 Mar 2011 14:27:36 -0600 – Beginning import of version 1944 of site Client Manager for Anti-Virus

Thu, 10 Mar 2011 18:33:01 -0600 – Beginning import of version 746 of site BES Support

Thu, 10 Mar 2011 19:34:07 -0600 – Beginning import of version 189 of site Patches for Mac OS X

Fri, 11 Mar 2011 14:23:14 -0600 – Beginning import of version 324 of site Updates for Windows Applications

Fri, 11 Mar 2011 14:23:49 -0600 – Beginning import of version 26 of site Windows Point of Sale

Fri, 11 Mar 2011 16:24:35 -0600 – Beginning import of version 1945 of site Client Manager for Anti-Virus

Fri, 11 Mar 2011 19:26:44 -0600 – Beginning import of version 747 of site BES Support

Mon, 14 Mar 2011 08:05:00 -0500 – Beginning import of version 2 of site Tivoli Remote Control

Mon, 14 Mar 2011 08:06:04 -0500 – Beginning import of version 1 of site Software Distribution

Mon, 14 Mar 2011 12:08:43 -0500 – Beginning import of version 748 of site BES Support

Mon, 14 Mar 2011 14:34:22 -0500 – Beginning import of version 1946 of site Client Manager for Anti-Virus

Mon, 14 Mar 2011 15:31:50 -0500 – Beginning import of version 15 of site Device Management for Windows Mobile

Mon, 14 Mar 2011 18:35:15 -0500 – Beginning import of version 19 of site BigFix DSS Software Asset Management

Mon, 14 Mar 2011 19:31:25 -0500 – Beginning import of version 409 of site Patches for SUSE Linux Enterprise

Tue, 15 Mar 2011 08:02:33 -0500 – Beginning import of version 307 of site Patches for Windows (Hungarian)

Tue, 15 Mar 2011 15:08:24 -0500 – Beginning import of version 1947 of site Client Manager for Anti-Virus

Tue, 15 Mar 2011 16:09:41 -0500 – Beginning import of version 20 of site Power Management

(imported comment written by StacyLee)

I reinstalled my DEV Server today and I was not able to enable ANY sites from the license overview page. Several hours later I am not able to enable a

bunch

of sites including the OS Deployment site.

Did something get fixed? I did email licensing to let them know the situation, so maybe something

magical

happened !

(imported comment written by SystemAdmin)

I just checked this morning and the OSD is now “enable”-ing properly. I am subscribing a set of computers to this site and will start poking at it today.

Thanks for any behind the scenes stuff from the IBM/BigFix team in getting this site to work.

Now the fun begins…

(imported comment written by SystemAdmin)

Still no love here. Did both of you have to email licensing first before it worked?

(imported comment written by SystemAdmin)

I did email licensing but I used the old @bigfix.com address (never got around to resending to the @ibm address) when I didnt have the Remote Control piece either. I never heard anything back from them.

I also had some emails with some of the IBM team from last week, not sure if they worked anything behind the scenes but I never heard back from them either. I just tried every day and it just happened to work today.

I believe I did “check for license update” last night and when i logged in this morning I had to close/reopen the console due to DB error. After i opened the console back up it worked.

I got some work ahead of me to start testing it out but the Health Check dashboard looks helpful but I have about 30 pages of documentation that I want to go through to make sure I set this up correctly.

(imported comment written by JackCoates91)

hey guys,

I just got an email indicating this was resolved on our side… any love on your side?

thanks,

Jack

(imported comment written by StacyLee)

<==GROUP HUG==>

It works now !! I can enable the site now!!!

(imported comment written by JackCoates91)

Excellent! Who’s in for a wild weekend of deploying Windows 7!?

(imported comment written by SystemAdmin)

Liek Stacy said - <==GROUP HUG==>

Jack - Do we have to wait for the weekend? :slight_smile:

Ok, now we just need multicast and bare metal… Can you get that resolved too :wink:

(imported comment written by SystemAdmin)

Has anyone started using this feature yet?

We are running into some issues in capturing images and I am not sure my MDT Bundle is correct.

Basically I can run the job to capture the image, it will run successfully but nothing gets uploaded to the share. When I log into the machine that I am running this task on it is about half way through the “Running: Lite Touch Installation” and it is looking for some files from the Win XP SP3 disk. It is trying to pull the files from c:\deploy$oem$\bigfixosd\driversxpms\i386 but it doesnt look like that i386 folder exists.

I believe my issue might start with the MDT bundle and maybe it just did not upload properly into the server. When I look at the Upload MDT Bundle Wizard I see files for MDT (393 MB), XP x86 (12.14 MB), W7 x86 (215 MB), and W7 x64 (244 MB). We are not going to be doing Vista or XP x64 at this time so we skipped those when creating the MDT bundle. All of the items have Warnings on the right hand side that “File Upload in Progress” but that was over 5 days ago. I am also concerned that the XP size is significantly less then the other OS’s. (see attached image).

So I guess my question is, has anyone been able to get an image uploaded successfully and have used this OSD for image deployment?

We are in the process of updating our Windows 7 image and once that is complete I am going to try to upload that instead of an XP machine.

(imported comment written by JasonHonda)

The sizes for the uploaded bundles seems about correct. If the warning is still saying “File Upload in Progress” that may be where to start looking.

(imported comment written by JackCoates91)

Hi tsikma, under Maintenance and Configuration, do you have a “BigFix OS Deployment - Updated BES Upload Maintenance Service” fixlet that’s relevant?

(imported comment written by SystemAdmin)

The only thing that is relevent of the 10 items in here is the Download Microsoft C++ 2005 Redistributable Package (x86).

Under the health checks everything is a Pass status except for At least one image has been uploaded (obviously since that is my issue).

I looked at the URL for the MDT bundle and the OS information and it looks like they are in the correct folders under C:\Program Files (x86)\BigFix Enterprise\BES Server\wwwrootbes\Uploads on the server

(imported comment written by JackCoates91)

can you email me your OSD_UMS.log and MFS.Log from C:\Program Files (x86)\BigFix Enterprise\BES Server\Applications\Logs ? jcoates at us ibm com

(imported comment written by SystemAdmin)

Hi Team,

After TEM deployment, I don’t see OS Deployment option. How can I make this option available in console. I am using Evaluation version.

Thanks,

Faraz