Error enabling SSL for webreports on IEM 9.0

(imported topic written by SystemAdmin)

Hello, i’ve tried to enable SSL on my webreports site.

I’ve follow the instructions on TivoliEndpoint_Manager_webreports.pdf and i’ve modified the proprietis of the server.

_WebReports_HTTPServer_UseSSLFlag to 1

_WebReports_HTTPServer_SSLCertificateFilePath with path of my PEM

_WebReportsHTTPServer_PortNumber 443

_WebReports_HTTPRedirect_Enabled to 1

_WebReports_HTTPRedirect_PortNumber to 80

and i’ve restarted my webreports with

/etc/init.d/beswebreports restart

After that the redirect from 80 to 443 works fine , but SSL are not working yet.

With netstat i’ve saw 443 port is not UP.

Any way to debut this? What kind of log i could see? I’m quite new to IBM Endpoint Manager !

I’ve tried to set the log adding the section in /var/opt/BESWebReportsServer/

BESwebreports.config but the log as not appered.

(imported comment written by Chris.Luther)

A couple of comments:

  • This is probably a typo in your port, but the setting is _WebReports_HTTPServer_PortNumber
  • Have you checked out the Setup for SSL on Tivoli Endpoint Manager Web Reports technote? It has a lot of useful information.

The most common problems are:

  • The certificate for Web Reports is not in PEM format;
  • Forgot to include the certificate’s unprotected private key in the server’s certificate file

The aforementioned technote covers a lot of this information.