Action Status Download Failed (IEM 9)

(imported topic written by dgowan777)

Dear dW,

Recent IEM 9 installation on Windows 2008 R2 64bit with SQL 2012.

I’m having problems when I attempt to install a Relay or Upgrade the client from v8 to v9. I’ve populated all operator sites, checked the gatherdb logs, client logs, and the only thing I’ve found is in the client log:

At 18:21:22 -0700 - opsite2 (http://WINSVR01.gowanhome.net:52311/cgi-bin/bfgather.exe/opsite2)

FAILED to Synchronize - General transport failure. - ‘http://WINSVR01.gowanhome.net:52311/cgi-bin/bfenterprise/BESGatherMirror.exe?url=http://WINSVR01.gowanhome.net:52311/cgi-bin/bfgather.exe/opsite2&Time=14May18:21:22&rand=8a65c139&ManyVersionSha1=da39a3ee5e6b4b0d3255bfef95601890afd80709’ http failure code 404 - gather url - http://WINSVR01.gowanhome.net:52311/cgi-bin/bfenterprise/BESGatherMirror.exe?url=http://WINSVR01.gowanhome.net:52311/cgi-bin/bfgather.exe/opsite2&Time=14May18:21:22&rand=8a65c139&ManyVersionSha1=da39a3ee5e6b4b0d3255bfef95601890afd80709

I’m not sure if this is related or not, but it’s all I’ve been able to find.

Any assistance is appreciated.

Thank you.

Darin

(imported comment written by DanielHwang)

Hey Darin,

Which Fixlet are you running to upgrade the relay? (If you reply back with the ID that would be sufficient.)

Do you have a proxy configured in your environment? If so, could you check to see that the settings are intact?

-Daniel Hwang

(imported comment written by dgowan777)

Hi Daniel.

I am running the following:

  • ID 1369 - Updated CentOS Linux Client (9.0.586)
  • ID 1363 - Install IEM Relay (9.0.586)

I selected these versions, as this is what my IEM server is running.

Thank you for your assistance. =D

Darin

(imported comment written by DanielHwang)

Thank you so much for your reply!

I’m assuming the machine you are upgrading is a CentOS machine. If the machine does not have a relay currently installed, you can run the following Fixlets to upgrade the client and install the relay:

  • ID 1369 - Updated CentOS Linux Client - IBM Endpoint Manager version 9.0.586.0
  • ID 1364 - Install IBM Endpoint Manager Relay on Linux and UNIX (Version 9.0.586.0) (Superseded)

If the machine already has a relay installed, you can simply run:

  • ID 1369 - Updated CentOS Linux Client - IBM Endpoint Manager version 9.0.586.0
  • ID 1376 - Updated Red Hat Enterprise Linux Relay - IBM Endpoint Manager version 9.0.586.0 Now Available!

The Fixlet ID 1363 is for Windows machines.

After running the appropriate Fixlets, please let me know if the upgrade went through! If it didn’t, please attach a screenshot of the error message in the Console. From there, we can work on getting additional diagnostic information.